Monthly Archives: September 2026

LXD container won’t start, “zpool is missing” after Ubuntu upgrade to 26.04

1 minute, 0 seconds

This is a quick PSA post to maybe help someone who is stuck trying to start an a LXD container after upgrading from Ubuntu 24 to Ubuntu 26 and you get an error:

Required tool ‘zpool’ is missing

My first many searches found folks upgrading alright, but upgrading to like Ubuntu 18?! Or another post was someone on Ubuntu 20? While they had the same error, their mention of a fix of setting zfs.external=true did not work for me.

While I would love to eventually migrate to Incus, I really wanted to get stable on Ubuntu 26 for both my servers before doing anything as invasive as an massive migration.

I noted that I was on LXD 5.0.10 which Canonical keeps up to date (release this month), but I also noticed that the latest Snap was LXD 5.21. Checking snap info lxd I could see I was on the 5.0.10-24fe763 track – so I switched to the latest stable with: snap refresh lxd --channel=5.21/stable

After that – boom – all containers started working. I see now, when I’m less panicked, that this was recommended in one of the threads I was looking at :shrug:.

So – if you’re stuck with the zpool error – try upgrading to the latest LXD! This should be a pretty low stakes test as you can just revert by going back to the older channel in the snap. Best of luck!